Are you interested in trying Noah ES for your business?

The first step is to make sure that your busines and PCs meet the following requirements to satisfactorily run Noah ES.

Initial Release in US and European Economic Area

The initial release of Noah ES will be limited to the US and to the European Economic Area (EEA) only. Your business must be located in one of these markets.

Future plans include expanding Noah ES offerings to more areas worldwide.

Business Systems and Mobile Apps not Currently Supported

Noah-compatible business systems and Noah Mobile apps are currently not able to integrate with Noah ES.

If you business relies on a Noah-compatible business system or Noah Mobile app, we suggest that you wait until integration is supported. This is scheduled to come later this year.

Reliable Stable Internet Access

An important requirement for Noah ES is a reliable, stable internet connection. Noah ES is a cloud based system and you will access your Noah database over the internet.

Noah ES requires at least 2Mbps download and 2Mbps upload speed.

If you are uncertain of your speed, please check at http://himsa.speedtestcustom.com.  You should check at each office and as a test, while connected outside of the office (e.g. connecting via a mobile hot spot).  Your speed connection tests should also be run during normal business hours to accurately measure your internet speed while other employees are making use of the internet connection.

Supported Web Browser

HIMSA will test and support latest versions of Chrome, Firefox, Safari, and Microsoft Edge. Internet Explorer (IE) is not supported.

Valid E-mail Address for Each User

A requirement for Noah ES is is a valid email address for each user. The email address is also the Noah ES user account name.

Supported Noah Version

Each computer using Noah ES will need to update or install a Noah ES supported version of Noah System, currently Noah 4.14.

For early release locations Noah ES is still compatible with Noah 4.13.

The Noah System 4 version you install must be supported on the PCs Windows operating system. Minimum computer requirements are located on the Minimum system requirements for Noah System 4 page of the HIMSA website.

Back to Noah ES